aboutsummaryrefslogtreecommitdiff
path: root/config.h.in
diff options
context:
space:
mode:
authorStefan Liebler <stli@linux.vnet.ibm.com>2016-04-04 12:54:22 +0200
committerMike Frysinger <vapier@gentoo.org>2016-04-04 14:58:54 -0400
commita3195f733dc383a8baeb0d178ee77b819efffaeb (patch)
treef074b852d01f964f2d11e5018aa43f9c34d02814 /config.h.in
parentee91916b2158b68b8730e1bf815260466b4d0cbc (diff)
downloadglibc-a3195f733dc383a8baeb0d178ee77b819efffaeb.tar
glibc-a3195f733dc383a8baeb0d178ee77b819efffaeb.tar.gz
glibc-a3195f733dc383a8baeb0d178ee77b819efffaeb.tar.bz2
glibc-a3195f733dc383a8baeb0d178ee77b819efffaeb.zip
S390: configure check for vector instruction support in assembler.
The S390 specific test checks if the assembler has support for the new z13 vector instructions by compiling a vector instruction. The .machine and .machinemode directives are needed to compile the vector instruction without -march=z13 option on 31/64 bit. On success the macro HAVE_S390_VX_ASM_SUPPORT is defined. This macro is used to determine if the optimized functions can be build without compile errors. If the used assembler lacks vector support, then a warning is dumped while configuring and only the common code functions are build. The z13 instruction support was introduced in "[Committed] S/390: Add support for IBM z13." (https://sourceware.org/ml/binutils/2015-01/msg00197.html) ChangeLog: * config.h.in (HAVE_S390_VX_ASM_SUPPORT): New macro undefine. * sysdeps/s390/configure.ac: Add test for S390 vector instruction assembler support. * sysdeps/s390/configure: Regenerated. (cherry picked from commit 4f0a1cea34c05fb2acc16f1a2d291f53230eb4fb) (cherry picked from commit 5fc92dc17d6a2eb6420cef33d8d6bd3a84bb968c)
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/config.h.in b/config.h.in
index 2b9aa1a986..8d44b8a7a9 100644
--- a/config.h.in
+++ b/config.h.in
@@ -91,6 +91,9 @@
/* Define if assembler supports AVX512. */
#undef HAVE_AVX512_ASM_SUPPORT
+/* Define if assembler supports vector instructions on S390. */
+#undef HAVE_S390_VX_ASM_SUPPORT
+
/* Define if assembler supports Intel MPX. */
#undef HAVE_MPX_SUPPORT