aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiddhesh Poyarekar <siddhesh@sourceware.org>2017-01-20 12:24:46 +0530
committerSiddhesh Poyarekar <siddhesh@sourceware.org>2017-01-20 12:32:46 +0530
commit56009aa33c735d66f19d8382b6ef7c6addc24ec0 (patch)
tree36a583805c3a6258e5d9a4bb79afff65f0915ce9
parentfe3f0488daaec2fb8c3af181b6e8e4567ba2cf61 (diff)
downloadglibc-56009aa33c735d66f19d8382b6ef7c6addc24ec0.tar
glibc-56009aa33c735d66f19d8382b6ef7c6addc24ec0.tar.gz
glibc-56009aa33c735d66f19d8382b6ef7c6addc24ec0.tar.bz2
glibc-56009aa33c735d66f19d8382b6ef7c6addc24ec0.zip
Add target to incorporate translations from translations.org
Add a convenience target for maintainers to download and incorporate translation updates from translations.org. Invoke as follows: make -r PARALLELMFLAGS="" -C ../po objdir=`pwd` update-translations similar to generating libc.pot. * po/Makefile (update-translations): New target.
-rw-r--r--ChangeLog4
-rw-r--r--po/Makefile11
2 files changed, 15 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 896231a0f1..d7c2d2e55b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2017-01-20 Siddhesh Poyarekar <siddhesh@sourceware.org>
+
+ * po/Makefile (update-translations): New target.
+
2017-01-19 Joseph Myers <joseph@codesourcery.com>
[BZ #21061]
diff --git a/po/Makefile b/po/Makefile
index 302c3b6db6..122db23591 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -109,3 +109,14 @@ linguas: $(pofiles:$(podir)/%=%)
linguas.mo: $(pofiles:$(podir)/%.po=%.mo)
endif
+
+# Update translations from the translation project.
+TRANSLATIONS_URL = https://translationproject.org/latest/libc
+WGET = wget
+
+update-translations:
+ $(WGET) -qO- $(TRANSLATIONS_URL) | sed -n 's|.*href="\([^"]\+po\)".*|\1|p' | \
+ while read f; do \
+ $(WGET) -O $(objdir)/$$f-tmp $(TRANSLATIONS_URL)/$$f && \
+ mv -f $(objdir)/$$f-tmp $$f; \
+ done