aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-01 02:15:48 -0400
committerMike Frysinger <vapier@gentoo.org>2017-02-09 00:48:37 -0500
commit1eff1226630034286c3ae5fa1376eb76211690df (patch)
treedc08ba8b94bf5f0d8826c55fd26ad8dd7f09e2cd
parentdb0242e3023436757bbc7c488a779e6e3343db04 (diff)
downloadglibc-1eff1226630034286c3ae5fa1376eb76211690df.tar
glibc-1eff1226630034286c3ae5fa1376eb76211690df.tar.gz
glibc-1eff1226630034286c3ae5fa1376eb76211690df.tar.bz2
glibc-1eff1226630034286c3ae5fa1376eb76211690df.zip
disable ldconfig during install
Do not bother running ldconfig on DESTDIR. It's a waste of time as we won't use the result (portage will rebuild the cache after install). Also, the Gentoo sandbox does not currently catch chroot() behavior so we end up (incorrectly) flagging it as a violation as a write to /etc. http://sourceware.org/ml/libc-alpha/2012-08/msg00118.html https://bugs.gentoo.org/431038
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 425cb796db..bf44b04672 100644
--- a/Makefile
+++ b/Makefile
@@ -107,6 +107,7 @@ install-symbolic-link: subdir_install
rm -f $(symbolic-link-list)
install:
+dont-bother-with-destdir:
-test ! -x $(elf-objpfx)ldconfig || LC_ALL=C \
$(elf-objpfx)ldconfig $(addprefix -r ,$(install_root)) \
$(slibdir) $(libdir)