aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-22 21:12:28 -0500
committerMike Frysinger <vapier@gentoo.org>2015-08-21 17:11:31 -0400
commit0acbb93ebb8cf2a646cc2b685cd13b22d52f1e27 (patch)
treea190b795be22ca6bc48fe1351206603ddceda33e
parent9ab172e7f88096d12a8a089ff2ef857d9a6cab38 (diff)
downloadglibc-0acbb93ebb8cf2a646cc2b685cd13b22d52f1e27.tar
glibc-0acbb93ebb8cf2a646cc2b685cd13b22d52f1e27.tar.gz
glibc-0acbb93ebb8cf2a646cc2b685cd13b22d52f1e27.tar.bz2
glibc-0acbb93ebb8cf2a646cc2b685cd13b22d52f1e27.zip
manual: skip build when perl is unavailable
Do not try to generate the manual when perl is unavailable. This matches the behavior when makeinfo is unavailable. Otherwise the install step fails when trying to generate the libm section since it runs a perl script. (cherry picked from commit 1695cdae065fa3693e7b18169a100f53444eac69)
-rw-r--r--manual/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/manual/Makefile b/manual/Makefile
index 53822082e2..cdb6763e9b 100644
--- a/manual/Makefile
+++ b/manual/Makefile
@@ -172,6 +172,8 @@ include ../Rules
.PHONY: install subdir_install install-data
install-data subdir_install: install
+# libm-err.texi generation requires perl.
+ifneq ($(PERL),no)
ifneq ($(strip $(MAKEINFO)),:)
install: $(inst_infodir)/libc.info
@if $(SHELL) -c '$(INSTALL_INFO) --version' >/dev/null 2>&1; then \
@@ -179,6 +181,7 @@ install: $(inst_infodir)/libc.info
$(INSTALL_INFO) --info-dir=$(inst_infodir) $(inst_infodir)/libc.info;\
else : ; fi
endif
+endif
# Catchall implicit rule for other installation targets from the parent.
install-%: ;