aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2014-09-09 17:41:57 -0400
committerMike Frysinger <vapier@gentoo.org>2015-02-09 10:02:06 -0500
commitf14f39cfd7b959c806d822a2f6863873151f0a83 (patch)
tree13e81c2166d5ce468e9db8cd9704560ccc850d96
parentc24bbd6de049a351efdb2a04f57a0000970f17b3 (diff)
downloadglibc-f14f39cfd7b959c806d822a2f6863873151f0a83.tar
glibc-f14f39cfd7b959c806d822a2f6863873151f0a83.tar.gz
glibc-f14f39cfd7b959c806d822a2f6863873151f0a83.tar.bz2
glibc-f14f39cfd7b959c806d822a2f6863873151f0a83.zip
disable PIE when checking for PIC default
When the compiler builds PIEs by default, the configure PIC check is confused into thinking PIC code is default. The end result is that we end up with only PIC being produced. Run the configure check with -fno-PIE so that we produce PIC & non-PIC (PIE) objects like normal. 2014-09-09 Kevin F. Quinn <kevquinn@gentoo.org> * configure.ac (libc_cv_pic_default): Pass -fno-PIE. * configure: Regenerated.
-rwxr-xr-xconfigure2
-rw-r--r--configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/configure b/configure
index ce0c6a01f1..70b4479b5e 100755
--- a/configure
+++ b/configure
@@ -7148,7 +7148,7 @@ cat > conftest.c <<EOF
# error PIC is default.
#endif
EOF
-if eval "${CC-cc} -S conftest.c 2>&5 1>&5"; then
+if eval "${CC-cc} -fno-PIE -S conftest.c 2>&5 1>&5"; then
libc_cv_pic_default=no
fi
rm -f conftest.*
diff --git a/configure.ac b/configure.ac
index d89aaf0cdf..9351483c1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2013,7 +2013,7 @@ cat > conftest.c <<EOF
# error PIC is default.
#endif
EOF
-if eval "${CC-cc} -S conftest.c 2>&AS_MESSAGE_LOG_FD 1>&AS_MESSAGE_LOG_FD"; then
+if eval "${CC-cc} -fno-PIE -S conftest.c 2>&AS_MESSAGE_LOG_FD 1>&AS_MESSAGE_LOG_FD"; then
libc_cv_pic_default=no
fi
rm -f conftest.*])