aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-04 14:07:11 -0400
committerMike Frysinger <vapier@gentoo.org>2015-02-09 09:57:23 -0500
commit1a8236dcac0e7d5aa5148d96da46b0f204b20140 (patch)
tree9ab6d093c632205205e97df353e3f8f69b488ba3
parent4e42b5b8f89f0e288e68be7ad70f9525aebc2cff (diff)
downloadglibc-1a8236dcac0e7d5aa5148d96da46b0f204b20140.tar
glibc-1a8236dcac0e7d5aa5148d96da46b0f204b20140.tar.gz
glibc-1a8236dcac0e7d5aa5148d96da46b0f204b20140.tar.bz2
glibc-1a8236dcac0e7d5aa5148d96da46b0f204b20140.zip
disable ldconfig during install
do not bother running ldconfig on DESTDIR. it wants to write the temp cache file outside of the chroot. doesnt matter anyways as we wont use the cache results (portage will rebuild cache), so running ldconfig is simply a waste of time. http://sourceware.org/ml/libc-alpha/2012-08/msg00118.html https://bugs.gentoo.org/431038
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 17e796fe1b..e25e8bead6 100644
--- a/Makefile
+++ b/Makefile
@@ -105,6 +105,7 @@ install-symbolic-link: subdir_install
rm -f $(symbolic-link-list)
install:
+dont-bother-with-destdir:
-test ! -x $(elf-objpfx)ldconfig || LC_ALL=C \
$(elf-objpfx)ldconfig $(addprefix -r ,$(install_root)) \
$(slibdir) $(libdir)